Составьте программу тренажер таблицы умножения на 8 в паскаль в конце посчитать количество правильных ответов

SOFIA0209 SOFIA0209    2   16.09.2019 19:30    2

Ответы
danila9988p09k31 danila9988p09k31  07.10.2020 20:24
Var
a:array[1..9] of boolean;
cnt,tmp,cur,all, i:integer;
begin
Writeln('Введите "0", чтобы закончить тестирование до
for i:= 1 to 9 do begin
 tmp:= 1 + random(9);
 while a[tmp] = true do
   tmp:= 1 + random(9);
 Write('8 * ',tmp,' = ');
 Read(cur); if cur = 0 then break;
 all:= all+1;
 if cur = 8*tmp then cnt:=cnt+1 else writeln('Wrong: ', 8*tmp);
 a[tmp]:=true;
end;
Writeln(cnt,'/',all);
end.

Пример:

Введите "0", чтобы закончить тестирование до
8 * 8 = 64
8 * 3 = 24
8 * 5 = 45
Wrong: 40
8 * 7 = 0
2/3
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика