Составьте программу решения квадратного уравнения ax(во второй степени) + bx + c = 0. коэффициенты a,b,c введите с клавиатуры. выведите на экран значение корней x1,x2, если уравнение имеет два корня, значение x, если уравнение имеет один корень, или сообщение "нет корней" , если уравнение не имеет корней. составьте программу на уровне 8 класса.

1111Кристина11111 1111Кристина11111    3   11.06.2019 10:20    3

Ответы
donerkebab donerkebab  09.07.2020 12:26
var
  a, b, c: real;

begin
  readln(a, b, c);
  if (sqr(b) - 4 * a * c < 0) then
    writeln('Нет решений')
  else
    if (sqr(b) - 4 * a * c = 0) then
      writeln('x = ', (-1 * b) / (2 * a))
    else
    begin
      writeln('x1 = ', (-1 * b + sqrt(sqr(b) - 4 * a * c)) / (2 * a));
      writeln('x2 = ', (-1 * b - sqrt(sqr(b) - 4 * a * c)) / (2 * a));
    end;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика