tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Составьте программу, позволяющую
Составьте программу, позволяющую проверить правописание "жи" и "ши" в строке s. выведите на экран количество допущенных ошибок и исправленную строку.
ааа511
1 10.07.2019 10:50
4
Ответы
Rosa02
17.09.2020 12:07
Var
b,i:integer;
S:string;
Begin
Readln(S);
b:=0;
For i:=1 to length(s) do
if i<length(s) then begin
if (s[i]='ж') or (s[i]='ш') then if s[i+1]='ы' then begin s[i+1]:='и'; b:=b+1; end;
End;
Writeln(b);
Writeln(s);
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Элис6666666666
16.07.2019 20:20
Файл размером 1440 кбайт передается через некоторое соединение со скоростью 480 кбайт/с.определите размер файла (в кбайт), который нужно передать за такое же время...
полина20042012
28.06.2019 11:00
1.двухканальная (стерео) звукозапись с частотой дискретизации 16 кгц и 32-битным разрешением велась в течении 5 минут. сжатие данных не производилось.какая из ниже...
alinamensikova
27.02.2021 13:43
1.какие действия могут выполняться над таблицей? очень важнл...
BoomerLass
07.05.2020 14:40
Разработать программу без функции pow C++...
Алексаднр
07.05.2020 14:40
с информатикой 12. Рассчитайте объем видеопамяти в Кб, необходимой для хранения графического изображения, если разрешающая монитора 640х480 и палитрой из 1024 цветов...
zulaykho001
07.05.2020 14:40
Двухфакторная линейная (билинейная) интерполяция...
MITSUHA
01.02.2021 20:49
Перевести числа з двійкової систему числення в десяткову: 1011010, 110100111 1011,1...
SvetaMew
01.02.2021 20:49
Дані дійсні числа х,у. вичислити я вичислити через FLOAT пайтон...
rita1501
01.02.2021 20:47
Написать программу в Паскалey=x-10ИS=1/2ah...
viktordemi2015
18.02.2020 12:13
Жиһанкез тау мен тасты, даланы аралады жалғасы керек...
Популярные вопросы
Сочинит мини сказку о скрюченном существе....
2
ответе на вопрос: из рассказа корзина с еловыми шишками. почему...
2
Найди закономерность, по которым составлены ряды, и продолжи каждый...
3
Молекулярная формула метанола и этанола,их свойства,применение...
3
Самолет летел от пункта а до б со скоростью 180 км/час , если бы...
1
Для птицефермы купили 500кг корма. из них 234 кг пшена, отрубей...
2
Помгите не сооброжаю хочу спать какие цифры можно поставить вместо...
1
Совершая цикл карно, газ отдал холодильнику 0,25 теплоты, полученной...
3
My its on . whats your friends favourite television...
1
Два парохода плывут навстречу друг другу скорость парохододов 32...
1
b,i:integer;
S:string;
Begin
Readln(S);
b:=0;
For i:=1 to length(s) do
if i<length(s) then begin
if (s[i]='ж') or (s[i]='ш') then if s[i+1]='ы' then begin s[i+1]:='и'; b:=b+1; end;
End;
Writeln(b);
Writeln(s);
End.