Составьте программу,по которой компьютер десять раз запросит ввод любых чисел и в результате выведет среднее арифметическое значение введенных чисел (массив не использовать).сделайте три варианта программы,используя операторы while,repeat ,for. заранее

vehera087 vehera087    1   21.06.2019 10:10    2

Ответы
drswag12312 drswag12312  16.07.2020 23:20
Int a, tmp1 = 0, tmp2 = 0;
1)while (tmp < 10) {
cin >> a;
tmp2 += a; }
cout << tmp2 / 10;
2)for (; tmp < 10; tmp++) {
cin >> a;
tmp2 += a; }
cout << tmp2 / 10;
3)repeat
cin >> a;
tmp2 += a;
until (tmp < 10)
cout << tmp2 / 10;
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика