Составьте программу, которая заполняет массив s [1..15] случайными целыми числами в диапазоне от -15 до 5 и находит количество элементов кратных 3.

georggeorg georggeorg    1   12.07.2019 17:20    0

Ответы
rigorevich17 rigorevich17  15.09.2020 13:47
Var
a:array [1..30] of integer;  // тут можешь регулировать количество чисел
i,k,n:integer;
begin
k:=0;
writeln('введите количество чисел от 1 до 30');
read(n);
randomize;
for i:=1 to n do begin
a[i]:=random(16)-5;
write(a[i]:3);
end;
writeln();
for i:=1 to n do if (a[i] mod 3=0) and (a[i]<>0) then k:=k+1;
writeln(k);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика