tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Составьте программу которая
Составьте программу которая в массиве a из 20 произвольных чисел находит произведение минимального элемента и среднего арифметического элементов данного массива
Ларкия
1 19.08.2019 22:50
1
Ответы
alinaklepcova
14.08.2020 17:18
Лови)
const
k = 20;
var
A: array [1..k] of real;
i: integer;
min, average: real;
begin
writeln('Enter x:');
for i := 1 to k do
begin
A[i] := random(k);
writeln('A[', i, '] = ', A[i]);
end;
min := A[i];
average := 0;
for i := 1 to k do
begin
average := average + A[i] / k;
if min > A[i] then
min := A[i];
end;
writeln(min * average);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Про100олюшка
19.11.2019 23:11
Влингвистической школе три языка: рапа, маори и киаи. в группе из 31 человека каждый изучает один или три языка. язык рапа изучают 17 человек, маори - 15 человек, киаи - 11 человек....
Bro1221
16.10.2021 21:01
, с подробным решением. 4.Переведите число 155 из десятичной системы счисления в двоичную систему счисления.Сколько единиц содержит полученное число?В ответе укажите одно число-количество...
LadyDay
28.05.2019 04:20
Сколько секунд потребуется модему, пере- сообщения со скоростью 128800 бит/с, чтобы передать 113 страниц текста в 40 строк по 65 символов каждая, при усло-вии, что каждый символ...
aaapruda
28.05.2019 04:20
Создать файл,в которм хранятся данные о работающих на фабрике: фамилия,имя,отчество,адрес(улица,дом,квартира) и дата поступления на работу(месяц,год). во второй файл записать...
lolologhka
03.07.2019 16:20
Как будет по слово я тебя ненавижу...
vfffffffff
03.07.2019 16:20
Решите иррациональное уравнение: корень из 2x+5-корень из 3x-5=2...
BlackVaiNor
03.07.2019 16:20
Ағзасының біртұтастығы. тауып берініздерші!...
еренйегер2398
03.07.2019 16:20
Составьте 7-8 предложений об осени....
Ḱặрặṃềӆьҟӑ
03.07.2019 16:20
960-640: (4+4)×2=сколько будет и как вы делали напишите...
andreweeoneoff
03.07.2019 16:20
Найдите наибольший общий делитель числа: а) 585 и 360. б) 680 и 612. в) 60,80 и 48. г) 195, 156 и 260. !...
Популярные вопросы
Сколькими можно распределить 12 человек по по 6 человек в каждой?...
3
ответить на вопрос викторины. тематика викторины поиграем в города . учитывая...
1
Впонедельник собрали свеклы на 20% меньше, чем во фторник, а в среду- на 40%...
3
Втреугольнике abc стороны ab и bc равны, k-середина ac, bc = 13 см.на сторонах...
3
Какие бывают формы растений? тема: жизненные формы покрытосеменных растений...
2
Рассказ имя существительное как часть речи...
3
Разберите по составу слова январьский,загорится,бездонное,лампочка! заранее...
2
Аа.. ) нужно написать топик, не сложный. всего 10 предложение можно чуть побольше))...
1
Найдите боковую сторону равнобедренного треугольника,если его периметр равен...
1
Представить дробь 8/24 в ввиде дроби со знаменателем 3...
3
const
k = 20;
var
A: array [1..k] of real;
i: integer;
min, average: real;
begin
writeln('Enter x:');
for i := 1 to k do
begin
A[i] := random(k);
writeln('A[', i, '] = ', A[i]);
end;
min := A[i];
average := 0;
for i := 1 to k do
begin
average := average + A[i] / k;
if min > A[i] then
min := A[i];
end;
writeln(min * average);
end.