Составьте программу которая по введёному числу с клавиатуры возведёт его в квадрат если это данное число будет чётным. (пример program p1, writeln итд)

5352352356 5352352356    3   12.03.2019 04:00    0

Ответы
радмир1115678 радмир1115678  24.05.2020 23:23

Program p1;

var a: real;

begin

Writeln('Vvedite chislo'); Read(a);  //Считаываем

If a mod 2=0 then writeln(a*a);  

//если остаток от делания на 2= 0, тогда пишем возведенное в квадрат число

end.

ПОКАЗАТЬ ОТВЕТЫ
админ1273 админ1273  24.05.2020 23:23

Program n1;
Uses CRT;
Var x: integer;
begin
ClrScr;
Writeln('Vvedite chislo');
Readln(x);
If x mod 2=0 then writeln('kvadrat =',x*x)
else writeln('nechetnoye');
readln
end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика