Составьте программу, которая определяет число разрядов заданного натурального числа n (подсказка: сколько раз должна выполняться n=n div 10, чтобы получилось n=0)

аружан225 аружан225    1   21.08.2019 22:30    4

Ответы
isheh09ow2mth isheh09ow2mth  24.04.2020 14:55
Program n1;
var c: longint;
function ch(n: longint ): longint;
var i: longint;
begin
i := 0;
while n > 0 do
begin
n := n div 10;
i := i + 1
end;
ch:= i
end;
begin
write ('Введите число: ');
readln (c);
if c<0 then c:=abs(c);
writeln ('в этом числе ',ch(c),' разрядов ');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика