Составьте программу,которая формирует массив из 11 случайных целых чисел от -10 до 5 и все положительные элементы возводит в квадрат

LizaVasilenko3636 LizaVasilenko3636    2   11.09.2019 18:20    4

Ответы
Маша10578 Маша10578  10.09.2020 01:53

var

 i, s: integer;

 a: array [1..11] of integer;

begin

 randomize;

 writeln('Chislo   ', 'Kvadrat chisel');

 for i := 1 to 11 do

 begin

   a[i] := Random(16) - 10;

   write(a[i]:4);  

   if (a[i]>0) then writeln(sqr(a[i]):12)

   else writeln('-':12);

 end;

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика