Составьте программу, котоая печатает слово true, если указанное высказываени является истинным, и false в противном случае цифры исходного четырехзначного числа n образуют строго возрастающую последовательность входные данные на вход подается число n (1000< =n< =9999) выходные данные true - если все цифры числа образуют строго возрастающую последовательность false - в противном случае пример: вход: 1234 вывод: true пример: вход: 1224 вывод: false вот моя программа { int n, a, b, c, d; scanf("%d",& n); a=n%10; b=n/10%10; c=n/100%10; d=n/1000; if ( b==a+1 & & c==a+2 & & d==a+3) printf("true"); else printf("false"); } в любом случае выводит фолс

Darieva Darieva    3   14.09.2019 21:50    0

Ответы
Екатерина2610 Екатерина2610  26.08.2020 20:53
if ( b==a+1 && c==a+2 && d==a+3) printf("true");

заменить на следующий

if ((a>b) && (b>c) && (c>d)) printf("true");
ПОКАЗАТЬ ОТВЕТЫ
AkiraK666 AkiraK666  26.08.2020 20:53
ОТДЕЛ Задание+;
ИСПОЛЬЗУЕТ Вывод ИЗ "...\Отделы\Обмен\", Приём ИЗ "...\Отделы\Обмен\";

ПЕР
  число: ЦЕЛ;

УКАЗ
  число := Приём.Число(); Вывод.Цепь("^");
  ЕСЛИ
    число ДЕЛИТЬ 1000 < число ДЕЛИТЬ 100 ОСТАТОК 10 И
    число ДЕЛИТЬ 100 ОСТАТОК 10 < число ДЕЛИТЬ 10 ОСТАТОК 10 И
    число ДЕЛИТЬ 10 ОСТАТОК 10 < число ОСТАТОК 10
  ТО
    Вывод.Цепь("труе")
  ИНАЧЕ
    Вывод.Цепь("фалсе")
  КОН

КОН Задание.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика