tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Составьте программу для
Составьте программу для вычисления косинусов углов треугольника со сторонами a, b, c. указание. примените теорему косинусов: c2=a2 + b2 -2ab * cos α
Nezilik
1 14.07.2019 17:30
3
Ответы
katyafedorenko1
07.09.2020 11:45
Var a,b,c,cosa, cosb, cosc:real;
begin
writeln('Введите стороны треугольника АВС');
read(a,b,c);
cosa:=(sqr(b)+sqr(c)-sqr(a))/(2*b*c);
cosb:=(sqr(c)+sqr(a)-sqr(b))/(2*c*a);
cosc:=(sqr(a)+sqr(b)-sqr(c))/(2*a*b);
writeln('Косинус угла А = ', cosa, ' Косинус угла В =', cosb,' Косинус угла C =', cosc);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
kymbat2016
11.09.2019 21:10
Уточните, каков объем оперативной памяти компьютера (у меня 4 гб),к которому вы имеете доступ дома или в школе .сколько страниц текста можно разместить в памяти этого компьютера...
7kotik7myr7myr7
11.09.2019 21:10
Вася отсканировал цветную фотографию размером 5,08 см х 5,08 см. параметры сканирования: цветопередача 65536 цветов, разрешение 512dpi. формат файла, в котором он сохранил фотографию,...
valenkov05
30.05.2023 18:50
с информатикой, писать на Пайтоне Розробити програму, дотримуючись таких вимог: - число n (кількість елементів списку) – іменована константа; - елементи списку – псевдовипадкові...
Динара010
30.05.2023 18:50
Проведіть обговорення та запишіть спільну думку стосовно плану підготовки до представ- лення результатів навчального проекту з математики «Ви- користання звичайних дробів [Дам 25б]...
likewithboss
30.05.2023 18:48
ЭКЗАМЕН ПО python Задание: Игра в Быки и коровы Описание задачи: Вы создаете игру в Быки и коровы . Это игра, в которой компьютер загадывает четырехзначное число, а игрок пытается...
6Evgeny11111
26.07.2019 11:30
Написать программу вычисления суммы цифр 4-значного числа...
smail520
26.07.2019 11:30
Напишите программу , которая вводит элементы цельночисленного массива размерностью 10 с клавиатуры и выводит номер этого элемента , равного 15. на паскале...
HELP2606
19.09.2019 19:20
Составить блок-схему и написать программу в эвм вводятся по очереди координаты n точек. определить, сколько из них попадает в круг радиусом r с центром в точке (a,b)....
RomansPirs
17.09.2019 22:20
Найти ошибку var a, b, c, d, x, k: integer; begin k=0 for x: = 1000 to do begin a: = x div 1000; b: = x div 100 mod 10; c: = x div 10 mod 10; d: = 0; a+b+c+d=10 then k: =k+1 end;...
макс3092
17.09.2019 23:10
Составить блок-схемы и программы для следующих : 1. запросить ввод чисел a и b с клавиатуры. найти сумму чисел s, произведение чисел m. вывести на экран результаты вычислений. 2....
Популярные вопросы
Забацайте, , 7 предложений со слово change...
2
Начерти 2 отрезка длина первого6 см а второго на 20 мм менше...
3
Как найди число в разряде десятков тысяч стоит цифра 5 б)12 063,106 727,30 009,485...
2
Тимур загадал число которое заканчивается цифрой 9. если отбросить последнюю цифру...
3
Еньшему общему знаменателю дроби 2/9 и 5/18...
2
Словосочетание: прибежал первым. какая часть речи у слов и на какие вопрос отвечают?...
1
Вкакой речевой ситуации мы пользуемся разговорным стилем? художественным? научно-деловой...
2
Морфологичиский разбор слов: арена,ножки,шар...
2
Текст на тему проблема бездомных животных...
3
Округлите до десятков до сотен до тысяч десятков тысяч число 62075 число 35909...
3
begin
writeln('Введите стороны треугольника АВС');
read(a,b,c);
cosa:=(sqr(b)+sqr(c)-sqr(a))/(2*b*c);
cosb:=(sqr(c)+sqr(a)-sqr(b))/(2*c*a);
cosc:=(sqr(a)+sqr(b)-sqr(c))/(2*a*b);
writeln('Косинус угла А = ', cosa, ' Косинус угла В =', cosb,' Косинус угла C =', cosc);
end.