Написать программу вычисления суммы цифр 4-значного числа

6Evgeny11111 6Evgeny11111    3   26.07.2019 11:30    2

Ответы
hbgggb hbgggb  24.09.2020 21:59
Var
  n, s: integer;

begin
  readln(n);
  n := abs(n);
 
  while n > 0 do
  begin
    s := s + n mod 10;
    n := n div 10;
  end;
  writeln(s);
end.

универсальный вариант, все равно сколько значное число
ПОКАЗАТЬ ОТВЕТЫ
ино7 ино7  24.09.2020 21:59
// Сделал Лугачев Кирилл
// Нахождение суммы 4-ёх значного числа
program sum;
var
sm:integer; // Сумма
n:integer; // Вводимое число
begin    
write('Введите 4-ех значное число: ');
readln(n);    
sm:=(n mod 10)+(n div 10 mod 10)+(n div 100 mod 10)+n div 1000;    
writeln('Сумма 4-ёх чисел: ',sm);    
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика