Составьте программу для паскаля. даны три числа. найти среди них произведение и количество отрицательных.

linakabak12345 linakabak12345    3   09.09.2019 20:50    3

Ответы
Кириллпронин Кириллпронин  07.10.2020 03:58
// PascalABC.NET 3.3, сборка 1573 от 04.11.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var (a,b,c):=ReadInteger3('Введите три целых числа:');
  var (p,k):=(int64(1),0);
  if a<0 then begin p:=p*a; k+=1 end;;
  if b<0 then begin p:=p*b; k+=1 end;
  if c<0 then begin p:=p*c; k+=1 end;
  Writeln('Произведение чисел равно ',p);
  Writeln('Количество отрицательных чисел равно ',k);
end.

Пример
Введите три целых числа: 12345 -67891011 -1213141516
Произведение чисел равно 82361404007312676
Количество отрицательных чисел равно 2
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика