Составьте быстро! 1)составьте программу вычесления суммы s=1+2^2+3^3+4^4++n^n. 2)даны годовые оценки учеников класса по .верно ли ,что количесвто пятерок больше,чем двоек? 3)известна высота двадцати зданий.найти минимальную высоту. 4известна высота двадцати зданий.найти два максимальный значения

enotzdrt enotzdrt    2   14.06.2019 00:00    2

Ответы
julss11 julss11  10.07.2020 19:55
Var p, q: longint;
  n, i, j, c: integer;
begin 
  // 1
  write('n=');readln(n);
  for i := 1 to n do begin
    q := 1;
    for j := 1 to i do q := q * i;
    p := p + q;
  end;
  writeln ('Значение = ', p);
  
  // 2
  write('Число годовых оценок=');readln(n);
  p:=0;
  for i := 1 to n do begin
    write('оценка: '); readln(c);
    if c = 5 then p := p + 1
    else if c = 2 then p := - 1;
  end;
  writeln(p > 0);
  
  // 3
  n := 20; p := MaxInt;
  for i := 1 to n do begin
    write('Введите высоту здания ', i, ': ');
    readln(c);
    if c < p then p := c;
  end;
  writeln('Минимальная высота: ', p);
  
  //4
  n := 20; p := -1;
  for i := 1 to n do begin
    write('Введите высоту здания ', i, ': ');
    readln(c);
    if c > p then p := c;
  end;
  writeln('Максимальное значение высоты: ', p);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика