Составить программу, вычисляющую площадь треугольника в паскаль

karinarigova2 karinarigova2    2   09.05.2020 18:34    4

Ответы
alesqwer alesqwer  14.10.2020 12:24

program z1;

var a,b,c,p: real;

begin

writeln('Определение площади треугольника по теореме Герона');

writeln('Введите стороны треугольника');

write ('a = ');

readln(a);

write ('b = ');

readln(b);

write ('c = ');

readln(c);

if (a + b <= c) or (b + c <= a) or (a + c <= b) then writeln ('Треугольника с такими сторонами не существует')

else

begin

p:=(a+b+c)/2;

writeln('Площадь треугольника равна ',sqrt(p*(p-a)*(p-b)*(p-c)):0:3)

end

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика