tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Составить программу вычисления
Составить программу вычисления суммы цифр двухзначного числа "a".значение "а",введите с клавиатуры.! надо(буду вам признательна *_*
evabo00
1 02.07.2019 15:30
2
Ответы
alena5378
02.10.2020 18:32
Должно работать и для двухзначного и для 3ехзначного и для 99999значного
var
a,sum:integer;
begin
readln(a);
while a>0 do
begin
sum:=sum+a mod 10;
a:=a div 10;
end;
writeln(sum);
end.
ПОКАЗАТЬ ОТВЕТЫ
ivanovgeorg123георг
02.10.2020 18:32
Pascal ABC
Var
A:integer;
Begin
Write('A = ');Read(A);
Write(A div 10,'+',A mod 10,' = ',(A div 10)+(A mod 10))
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
fff567
11.03.2019 16:20
Нужно написать программу на языке паскаль! : известен периметр прямоугольника и одна сторона из его сторон. найти площадь прямоугольника?...
Ommttika
20.04.2020 22:19
Составьте фрагмент программы, выводящий на экран...а) ...последнее слово строки st1, если строка состоит из нескольких слов, разделенных пробелами.(python) б) ...из строки st2 текст,...
Iliyz
20.04.2020 22:18
Excel графики функции y=1/(а...
MINLEMON
20.04.2020 22:18
Сколько страниц в тысячах будет найдено по за фрегат & эсминец *...
nik232451
20.04.2020 22:17
Определите объем памяти для хранения цифрового аудиофайла, время звучания которого составляет 2 минуты при частоте дискретизации 44,1 кГц и разрядности (глубине звука) 16 бит...
valera123zeerow4kam
21.07.2019 07:50
Почему когда снимешь с iphone защитное стекло, весь экран становится серый?...
damirnikiforov
21.07.2019 07:50
Имеется некоторая ip-сеть. в ней присутствуют: файловый сервер с адресом 192.170.100.3 mask 255.255.255.240, шлюз для выхода в интернет с адресом 192.170.100.1 mask 255.255.255.240,...
ghj42
21.07.2019 07:50
Графические обьекты каких видов можно нарисовать в paint...
Макоська
30.03.2019 13:48
2и 3 , нужен блок и программа в паскале...
dihochi
16.09.2019 21:20
Синформатикой! нужна нужно составить процедуру dв паскале которая создает массив из n целых чисел и выводит на экран любую подпоследовательность ячеек массива, создание таблицы...
Популярные вопросы
Зерттеуші үшін модель мен объектінің арасындағы ұқсастықты жазыңыз 3. «SketchUp»...
1
Деление обыкновенных дробей и смешанных чисел. Урок 3...
2
Перечислить составные части средневекового города. верных ответов :3 цитадель...
2
Это контрольная работа, мне нужно торопиться...
2
2 Complete the rules with still, yet, just and already. RULES1 We use — with...
3
1) прави2. Завжди м яким є приголоснийзвук:а) [в]; B) [й];б) [м]; г) [x]....
2
Соч по литературе седьмой класс...
2
сумма площадей квадратов построенных на соседних сторонах прямоугольника равна...
3
Опишите картинку на английском языке,по форме ОГЭ...
3
В каком году было сформулированы казачьи войско ...
3
var
a,sum:integer;
begin
readln(a);
while a>0 do
begin
sum:=sum+a mod 10;
a:=a div 10;
end;
writeln(sum);
end.
Var
A:integer;
Begin
Write('A = ');Read(A);
Write(A div 10,'+',A mod 10,' = ',(A div 10)+(A mod 10))
End.