tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Составить программу вычисления
Составить программу вычисления сумму цифр трех значнного числа
kseniya279
3 19.07.2019 09:20
1
Ответы
дэнчик60
03.10.2020 07:47
Program _1;
var x,a,b,c,s:integer;
begin
write('Введите исходное число');
readln(x);
a:=x div 100;
b:=x mod 100 div 10;
c:=x mod 10;
s:=a+b+c;
writeln('s=',s)
end.
ПОКАЗАТЬ ОТВЕТЫ
snegierevayanap08i8i
03.10.2020 07:47
Вот два варианта: с переводом числа в строку, и без. но здесь для 4х-значных чисел. по аналогии можно сделать и для 3х-значных. блин, фотки не прикрепились...
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Дура567
24.06.2019 01:40
Составить программу, которая из ряда целых двухзначных чисел рассчитывает сумму только тех чисел, цифры которых ....
Temka333333
24.06.2019 01:40
Алгоритм вычисления значений функций f(n) и g(n), где n – натуральное число, задан следующими соотношениями: f(1) = 1; g(1) = 1; f(n) = f(n–1) – 2*g(n–1), g(n) = f(n–1)...
DoctorVatson1
24.06.2019 01:40
Дан рекурсивный алгоритм: procedure f(n: integer); begin writeln( * ); if n 0 then begin f(n-3); f(n-2); f(n div 2); f(n div 2); end end; сколько символов звездочка будет...
morfinn
08.02.2022 14:00
Задача 1. Несжатое растровое изображение размером 64 х 512 пикселей занимает 32 Кб памяти. Каково максимально возможное число цветов в палитре изображения? Задача 2. Вычислите...
DIMAES0
24.10.2019 20:21
Правые частиограничения на время и память не задавалисьмаксимвльное количество : 60 правой частью натурального числа n назовем яисло к, полученное из двоичной записи n...
Rita210606
16.03.2021 16:20
2. ответь на вопросы. Свои ответы запиши в таблицу напротив вопросов. No 1 Вопросы Какой датчик запрограммирован на выполнение поворота робота на месте на точный угол?...
Intagul
24.04.2020 12:14
Композиція.Байка побудована на протиставленні двох героїнь (Муха і Бджола), їх ставленні до праці, розваг, власного призначення в житті.Експозиція: зустріч читача з Мухою,...
Uknowmyname
24.04.2020 12:14
4:Какая песня М. И. Глинки была гимном России?слово из 14 букв: )...
ZigZag1983
24.04.2020 12:14
Натрій карбонат повністю прореагував з розчином етанової кислоти масою 500 г з масовою часткою кислоти 6 %. Обчисліть маси натрій етаноату та води й об єм газу (н. у.),...
Belka1712
24.04.2020 11:30
20 член арифметичної прогресії дорівнює 30. Знайдіть суму 23 перших членів арифметичної прогресії...
Популярные вопросы
Крупнейшие центры промышленности Великобритании...
2
АЙТЫЛЫМ 10-тапсырма. «Қоржын» ойыны. Үш топқа бөлініңдер. Жеребе тас-тап,...
3
В правильной треугольной пирамиде боковое ребро создаёт с плоскостью...
1
Дві кулі масою 3кг і 5кг закріплені на кінцях стержня масою 1.8кг....
2
Переведите на китайский в иероглифике или пиньинь...
3
Би мен шешен дегеніміз кім...
1
тело при своем движении описало окружность радиусом 5м. чему равна...
2
2. По результатам выездной налоговой проверки коммерческой организации,...
3
Розрахуйте температуру повітря на різних висотах. Відомо, що на висоті...
2
Официальное название новообразованного казацкого государства 1648г-1649г...
3
var x,a,b,c,s:integer;
begin
write('Введите исходное число');
readln(x);
a:=x div 100;
b:=x mod 100 div 10;
c:=x mod 10;
s:=a+b+c;
writeln('s=',s)
end.