Составить программу вычисления произведения не нулевых элементов массива (а) вещественных чисел [1..5]

anitamirzikkk anitamirzikkk    3   15.03.2019 21:00    1

Ответы
nata960 nata960  25.05.2020 14:15

var 

  a: array [1..5] of real; //Массив из пяти вещественных элементов

  i: integer; //Переменная для цикла

  s: real; //Значение произведения

 

begin

  s:= 1;

  for i:= 1 to 5 do //Вводим элементы массива

  begin

    writeln('Введите ', i, ' элемент массива');

    readln(a[i]);

    if a[i] <> 0 then s:= s * a[i]; {Если элемент массива не равен 0, то умножаем значение произведения на элемент массива}

  end;

  writeln('Произведение не нулевых элементов массива:  ', s); {Выводим значение произведения}

end.

   

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика