tutotveti.ru
Предметы
Биология
Физика
Українська мова
Музыка
Французский язык
Обществознание
МХК
Право
ОБЖ
Психология
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Русский язык
Английский язык
Окружающий мир
Алгебра
Другие предметы
История
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Составить программу в паскале,!
Составить программу в паскале,! составить программу вычисления максимального значения функции y=x^2-3x+lnx при изменении аргумента x в интервале 1< =x< =5 с шагом 0.5
Yanika159
3 15.08.2019 13:30
0
Ответы
Benito84
04.10.2020 21:08
1. Современный вариант
// PascalABC.NET 3.2, сборка 1359 от 11.12.2016
// Внимание! Если программа не работает, обновите версию!
begin
Print(Range(1.0,5.0,Floor((5-1)/0.5)).Select(x->x*x-3*x+ln(x)).Max)
end.
Результат
11.6094379124341
2. Школьный вариант (ну вот так у нас в школах учат!)
var
x,y,max:real;
begin
max:=-1000;
x:=1;
while x<=5 do
begin
y:=sqr(x)-3*x+ln(x);
if max<y then max:=y;
x:=x+0.5
end;
Write(max)
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
anyanaffanya
13.05.2021 21:02
1. Определите размер графического файла, хранящего изображение размером 32 x 8 пикселей, если глубина цвета пикселя 4 бита. ответ дайте в байтах. 2. Определите информационный...
spiner21
13.05.2021 21:05
На рисунке — схема дорог, связывающих города А, Б, В, Г, Д, Е, Ж, З и И. По каждой дороге можно двигаться только в одном направлении, указанном стрелкой. Сколько существует различных...
danilgranin20
16.08.2019 08:50
Кто использует прикладные программы специального назначения?...
mbolzhatova
14.12.2020 19:21
Дан массив С(120) заполненный трехзначными случайными числами.Найти максимальный элемент массива и вывести его в паскале решить...
lesikon11
14.12.2020 19:20
Как скачать майнкрафт без компьютера и телефона олимпиада! ...
lenusja272
14.12.2020 19:19
5. Назовите сходства и различия растрового и векторного изображений на примере программ Paint.net и Inkscape...
ангел815
13.03.2019 10:50
Решить, нужно поставить знаки препинания nfr чтобы получился верный ответ 1100_11_100=100000 1100_10_10=100 100_10_10=110000...
ярослававас
13.03.2019 11:00
Информационный объем одного сообщения составляет 0,5 кбайт, а другого-128 битов. во сколько раз информационный объем первого сообщения больше объема второго сообщения?...
vakhtinanelli
13.03.2019 11:00
Информационное сообщение объемом 450 битов состоит из 150 символов каков информационный вес каждого символа этого сообщения?...
Диана149018
13.03.2019 10:12
К.р. по информатике.минимум 3 номера...
Популярные вопросы
1) Руслан кимдерди ээрчип басты? Эмне үчүн? 2) Алар эмне кылганды жакшы көрүшөт...
3
3. Учебные пособия, написанные И. Алтынсариным, назывались: а) Начальное руководство...
1
Кривошип ОА длиной 10 см вращается с постоянной угловойскоростью 2 рад/с....
3
B) Осы патшалықтардың бірін сипаттаңыз ...
3
Загальні резерви комерційних банків становлять 3 млрд. грн. Депозити цих банків...
3
Чому вчить твір. Машина для здійснення бажань, або Суботик повератється в...
1
терминологический диктант 1. При каком взаимодействии степень выраженности...
3
в каком преложении можно зоздать игру?...
3
Написать сочинение на английском языке. Тема: great places to go in the world...
2
Решите тест: А обеих сторон идти на уступки для урегулирования разногласий:...
1
// PascalABC.NET 3.2, сборка 1359 от 11.12.2016
// Внимание! Если программа не работает, обновите версию!
begin
Print(Range(1.0,5.0,Floor((5-1)/0.5)).Select(x->x*x-3*x+ln(x)).Max)
end.
Результат
11.6094379124341
2. Школьный вариант (ну вот так у нас в школах учат!)
var
x,y,max:real;
begin
max:=-1000;
x:=1;
while x<=5 do
begin
y:=sqr(x)-3*x+ln(x);
if max<y then max:=y;
x:=x+0.5
end;
Write(max)
end.