Составить программу в паскале.найдите произведение n членов арифметической прогрессии где a1=3 d=2.

kri2221 kri2221    3   21.05.2019 03:20    4

Ответы
Kristibabiba098 Kristibabiba098  01.10.2020 02:06

// у нас получается прогрессия вида 3 5 7 9 11 и.т.д 

Program AriphmP;

Uses Crt;

var a1,n,i:integer;

       p:longint;

begin

     clrscr;

      write('Введите количество членов прогресии n: ');

      readln(n);

      p:=1; a1:=3   

      for i:=2 to n do

            begin

                 p:=p*a1;

                 a1:=a1+2;

           end;   

 

   write('Произведение n-членов арифметической прогрессии: ',p);

    readkey;

end.

 

 

 

 

  

 

 

 

 

 

 

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика