Составить программу, в паскале, нахождения суммы цифр четырехзначного числа

BooWim BooWim    3   16.03.2019 14:00    2

Ответы
niavente niavente  25.05.2020 16:47

var

  a: 1000..9999; //Четырехзначное число

  a1, a2, a3, a4: 1..9;

 

begin 

  writeln('Введите четырехзначное число');

  readln(a);

  a1:= a mod 10;  //Первая с конца цифра

  a2:= (a mod 100) div 10;  //Вторая с конца цифра

  a3:= (a mod 1000) div 100;  //Третья с конца цифра

  a4:= a div 1000;  //Четвертая с конца цифра

  writeln('Сумма цифр данного числа:  ', a1 + a2 + a3 + a4);  //Сумма цифр

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика