Составить программу в паскале abc для решения следующей . с клавиатуры вводятся 3 произвольных числа. если второе число больше суммы первого и третьего , то вывести сумму этих двух чисел.если первое число положительное , то вывести среднее арифметическое трех чисел.

236784 236784    1   17.08.2019 19:00    2

Ответы
ротилуся1 ротилуся1  05.10.2020 01:19
Program qq;
uses CRT;
var x1,x2,x3,sum2,SrArVsChi:integer;
begin
write('Первое число равно ');
readln(x1);
write('Второе число равно ');
readln(x2);
write('Третье число равно ');
readln(x3);
if x2 > (x1+x3) then
sum2:=x1+x3;
writeln(sum2);
if x1 >= 0 then
SrArVsChi:=(x1+x2+x3)/3;
writeln(SrArVsChi);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика