Pascalabc. составьте программу, которая формирует массив из 15 случайных целых чисел, каждое из которых находится в диапазоне от -10 до 10 и выводит на экран: а) максимальный элемент массива б) индекс максимального элемента массива

danyaaseev2006 danyaaseev2006    1   04.10.2019 07:50    4

Ответы
rasimallamurato rasimallamurato  09.10.2020 19:07

program fantscrin;

 const n = 15;

 var a: array [1..n] of integer;

     i,max,max_i:integer;

Begin

 for i:=1 to n do

   a[i]:= random(21)-10;

 for i:=1 to n do

   write(a[i], '  ');

   

 max:=a[1];

 max_i:=1;

 for i:=2 to n do

   if (a[i]>max) then  

                 begin

                   max:=a[i];

                   max_i:=i;

                 end;

 writeln('');

 writeln('Элемент: ', max);

 writeln('Индекс: ', max_i);

End.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика