Составить программу в паскаль: дано число меньше 16 определить - сколько единичных битов содержит двоичная запись этого числа.

виолетта111111111113 виолетта111111111113    1   26.06.2019 16:10    3

Ответы
GordienkoA20 GordienkoA20  21.07.2020 12:09
Var b,a,c,kol:integer;
 begin 
writeln('введите число в десятичной системе счисления');
 readln(a); 
 kol:=0; 
 while(a>=2) do  begin 
      c:=a div 2; 
      b:=2*c; 
      b:=a-b; 
      writeln(b); 
      a:=c; 
     if a<2 then 
     writeln(a); 
     if a > 0 then 
     kol:=kol+1; 
end; 
writeln('количество 'kol);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика