Составить программу в паскаль абс и блок-схему: в заданной целочисленной квадратной матрице заменить нулями минимальные элементы каждой строки

HeU3BecN0cTb HeU3BecN0cTb    3   05.08.2019 18:40    4

Ответы
ViktoriaTigra ViktoriaTigra  03.10.2020 23:47
//PascalABC.NET 3.2 сборка 1318

Const
 n=3;
 m=2;

Var
  ma:array[1..n,1..m] of integer;
  i,j,min:integer;
begin
for i:=1 to n do
begin
min:=integer.MaxValue;
  for j:=1 to m do
    begin
      readln(ma[i,j]);
      if ma[i,j]<min then min:=ma[i,j];
    end;
  for j:=1 to m do
    if ma[i,j]=min then ma[i,j]:=0;
end;
writeln('Final matrix:');
for i:=1 to n do
begin
  for j:=1 to m do
    write(ma[i,j]:4);
writeln;
end;
end.
Составить программу в паскаль абс и блок-схему: в заданной целочисленной квадратной матрице заменить
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика