Составить программу, в которой каждый элемент массива возводится в квадрат

9251530703 9251530703    3   01.10.2019 22:30    1

Ответы
асаса3 асаса3  09.10.2020 10:30
PascalABC.NET 3.4.2, сборка 1864 от 11.11.2018Внимание! Если программа не работает, обновите версию!

begin

 var a := ArrRandom(ReadInteger('n='), -50, 50);

 a.Println;

 a.Transform(t -> t * t);

 a.Println

end.

Пример

n= 13

39 -13 48 8 34 -15 -13 -25 -43 -38 4 36 14

1521 169 2304 64 1156 225 169 625 1849 1444 16 1296 196

ПОКАЗАТЬ ОТВЕТЫ
dimapivovarov dimapivovarov  09.10.2020 10:30

const n=10;

var a:array [1..n] of integer;

i:integer;

begin

for i:=1 to n do a[i]:=random(9)+1;

writeln('Исходный массив: ',a);

for i:=1 to n do a[i]:=a[i]*a[i];

writeln('Преобразованный массив: ',a)

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика