Составить программу в c++ и по возможности блок-схему.
вот как выглядит программа в паскале
program z1;
var
q,x,y,z,a,b,c,d,e: integer;
w: real;
begin
writeln('введите x');
readln(x);
writeln('введите y');
readln(y);
writeln('введите z');
readln(z);
a: =x*y*z;
b: =3*z*x;
c: =2*(x+y+z);
d: =max(a,b);
e: =max(b,c);
q: =max(e,d);
writeln('максимум',q);
w: =min(3*x*y*z,q/2);
writeln('минимум',w);
end.

UliaAndKisas UliaAndKisas    3   08.12.2019 16:07    1

Ответы
мария1965 мария1965  03.09.2020 10:52

Переделал программу с паскаля на С++

#include <iostream>

#include <cstdlib>

#include <time.h>

using namespace std;

int main(){

srand(time(0));

system("chcp 1251 > nul");

int q,x,y,z,a,b,c,d,e;

double w;

cout << "Введите x: ";

cin >> x;

cout << "Введите y: ";

cin >> y;

cout << "Введите z: ";

cin >> z;

a = x*y*z;

b = 3*z*x;

c = 2*(x+y+z);

d = max(a,b);

e = max(b,c);

q = max(e,d);

cout << "Максимум: " << q<< endl;

w = min((3*x*y*z),(q/2));

cout << "Максимум: " << w << endl;

   return 0;

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика