tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Составить программу, считывает
Составить программу, считывает 2 числа, если сумма этих чисел кратно 3, то результат уменьшает в 3 раза, в противном случае оставляет без изменений.
nagibala09Никичан
3 16.09.2019 13:50
3
Ответы
LebedevAleksand
07.10.2020 19:49
На c++, если тебе надо считывание с файла, то ответь я переделаю.
#include <iostream>using namespace std;int main(){ int a,b; cin>>a>>b; if((a+b)%3==0) cout<<(a+b)/3<<endl; else cout<<a+b<<endl; return 0;}
ПОКАЗАТЬ ОТВЕТЫ
hristina112
07.10.2020 19:49
// PascalABC.NET 3.3, сборка 1625 от 17.01.2018
// Внимание! Если программа не работает, обновите версию!
begin
var (a,b):=ReadInteger2('Введите через пробел два числа');
var r:=a+b;
if r mod 3=0 then Writeln(r/3)
else Writeln(r)
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
1234554321111
19.05.2019 14:50
Информатика 9 класс. найти длину окружности и s круга. сделать проверку ввода....
simeika98p0c45h
01.06.2019 07:40
Решить ) begin11°(в №3). даны два ненулевых числа. найти сумму, разность, произведение и частное их модулей.входные данные: ввести два целых числа а и b (1 =a,b =100).выходные...
12233454647758886776
01.06.2019 07:40
1.201(10)+100(2) ответ в десятичной системе 2.103(10)+10(2) ответ в двоичной системе 3.1101(2)-11(2) ответ в двоичной системе 4.101(2)*10(2) ответ в десятичной системе...
СофияПодставкина
01.06.2019 07:40
Назови свойство, которое есть у всех этих объектов: камень, куст, дерево, цветок....
79033404606
07.05.2020 09:09
Узнать чистоту и разрядность...
05Goryanka05
07.05.2020 09:09
Решите задачу по информатике Марина сделала презентацию и решила отправить её Диме. Определите, сколько для этого понадобится времени (в минутах), если объём презентации равен...
progonskaij
19.07.2019 01:50
Составить программу ! составьте программу выводящего таблицу умножения любого введённого числа...
aika113
14.12.2020 16:51
ДАЮ 30 Б 1. Запишите наименьшее основание системы счисления, в которой числа могут быть записаны следующим образом: 10,45,101,33 2. Сколько единиц в двоичной записи числа...
nekiti444
06.10.2019 07:01
Уменя завтра сочинение на тему макро и хозяин джунглей,я не знаю как подготовиться и не могу найти информацию надо по литре...
elyakhina1976
06.10.2019 07:01
Анализ стихотворен любовной лирики некрасова...
Популярные вопросы
/ ЭТО ФИГУРНАЯ СКОБКА / х+4у=6 \5х-у=-9...
3
Упрастите выражение, алгебра 9 класс...
3
КОМБИНАТОРИКА!! Как решить задачу про садовника youtube.com/watch?v=uZI8bMYvMxc...
1
выполнить соч по русскому языку 3 класс...
1
как мне правильно ответить на эти во это суммативное работа...
3
Какой персοнаж гулял«.. на дне у меня...» в стихотворении М.Ю. Лермοнтοва...
1
На поверхность серебра падает свет с длиной волны 155 нм. Работа выхода...
3
Сравните текст А и текст Б, данные в таблице № 1. Определите сходства и...
2
Каким словом можно заменить слово задиристый...
3
В) составь цепь питания, включив в нее перечисленные организмы: гусеница,...
3
#include <iostream>using namespace std;int main(){ int a,b; cin>>a>>b; if((a+b)%3==0) cout<<(a+b)/3<<endl; else cout<<a+b<<endl; return 0;}
// Внимание! Если программа не работает, обновите версию!
begin
var (a,b):=ReadInteger2('Введите через пробел два числа');
var r:=a+b;
if r mod 3=0 then Writeln(r/3)
else Writeln(r)
end.