tutotveti.ru
Предметы
Биология
Физика
Українська мова
Музыка
Французский язык
Обществознание
МХК
Право
ОБЖ
Психология
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Русский язык
Английский язык
Окружающий мир
Алгебра
Другие предметы
История
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Составить программу, решающую
Составить программу, решающую следующую : вы продавец, и у вас имеются гири весом 1, 2, 5 кг. наберите минимальное количество гирь для взвешивания n кг.язык программирования-паскаль
agargo228
2 25.05.2019 06:30
8
Ответы
polishululyana
21.06.2020 07:23
Var N, a, b: integer;
begin
readln(N);
a := N div 5;
N := N mod 5;
b := N div 2;
WriteLn(a, 'x5, ', b, 'x2, ', N mod 2, 'x1');
end.
Вот так, делением можно)
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
123654789e
24.07.2019 12:20
Вячейках а1 в1 с1 электронной таблицы хранятся числовые значения. в ячейку d1 занесите логическое выражение принимающее значение истина только тогда, когда среди этих...
Luska1367
21.02.2021 14:31
Изучить предложенный код программы и определимся результат выполнения при а=2 b=-4...
Xa4Men771
30.11.2020 18:45
ПОЧЕМУ ПИШЕТ В ЭСКЕЛЬ ЧТО СЛИШКОМ МАЛО АРГУМЕНТОВ КАК ЭТО ИСПРАВИТЬ...
Фприт
30.11.2020 18:45
1. Закончите предложения! Кратко...
5Артём
30.11.2020 18:45
Домашнее задание На картинках представлены объекты культурногонаследия «Семь чудес Казахстана». Какие мастераискусств или специалисты их создавали? Найди инфор-мацию об...
flymisflymis
25.05.2020 13:57
На Python Треугольник Паскаля Даны два числа n и m. Создайте массив n×m и заполните его по следующим правилам: Числа, стоящие в строке 0 или в столбце 0 равны 1 (A[0][j]...
mun7890
25.05.2020 13:56
Некоторый алгоритм из одной цепочки символов получает новую цепочку следующим образом. Сначала вычисляется длина исходной цепочки символов; если она нечётна, то удаляется...
magamedgalaev9
26.08.2019 14:00
Составить программу - конвертер, которая запрашивает тип единицы измерения времени: 1 - секунда, 2 - минута, 3 - час, 4 - сутки, а также число - значение в этой единице...
epikhinanatuly
29.06.2019 23:50
Великие ученые и их открытия 16-18 вв. , нужно не меньше 10...
Arituk
29.06.2019 23:50
Какую роль играют ряды однородных членов?...
Популярные вопросы
Как найти периметр четырехугольника и выразить результат в миллиметрах...
1
Разберите слова лингвист как часть речи...
2
Определите знак выражения cos 2 * sin (-3)....
1
Как вы понимаете слова музыка окрыляет слова напишите, небольшое сочинение...
3
Как пишется не со словами сделал,позвал,согласился,развесили,прилетели...
2
На каких языках могли быть написаны клинописные таблички в библиотеке...
2
What does he do when he feels angry? ответьте на вопрос...
2
Match the words with there definitions 1-appreciate 2-together 3-worthwhile...
1
58б якщо напишете повну характеристику ребекки!...
3
Втрех пронумерованных пробирках находятся кристаллы : литий хлор, натрий...
2
begin
readln(N);
a := N div 5;
N := N mod 5;
b := N div 2;
WriteLn(a, 'x5, ', b, 'x2, ', N mod 2, 'x1');
end.
Вот так, делением можно)