Составить программу - конвертер, которая запрашивает тип единицы измерения времени: 1 - секунда, 2 - минута, 3 - час, 4 - сутки, а также число - значение в этой единице измерения времени и переводит данное число во все остальные единицы измерения времени. ввод чисел заканчивается нажатием клавиши 0. протокол работы программы: выберите тип единицы измерения времени: 1 - секунда, 2 - минута, 3 - час, 4 - сутки, 0 - выход. 1 введите значение этой единицы времени: 3600 ответ: 3600 сек = 60 мин = 1 час = 0,042 суток выберите тип единицы измерения времени: 1 - секунда, 2 - минута, 3 - час, 4 - сутки, 0 - выход. 4 введите значение этой единицы времени: 1 ответ: 1 суток = 24 час = 1440 мин = 86 400 сек выберите тип единицы измерения времени: 1 - секунда, 2 - минута, 3 - час, 4 - сутки, 0 - выход. 0 пока!

magamedgalaev9 magamedgalaev9    3   26.08.2019 14:00    1

Ответы
Fox125123 Fox125123  05.10.2020 21:04
Var A,R:integer;
Begin
WriteLn('Выберите тип единицы измерения времени: 1 - секунда, 2 - минута, 3 - час, 4 - сутки, 0 - выход.');
ReadLn(R);
While R<>0 do
   Begin
   Write('Введите значение этой единицы времени: ');
   ReadLn(A);
   Case R of
   1:WriteLn(A,' сек = ',(A/60):0:3,' мин = ',(A/3600):0:3,' ч = ',(A/86400):0:3,' сут');
   2:WriteLn(A,' мин = ',(A/60):0:3,' ч = ',(A/1440):0:3,' сут = ',A*60,' сек');
   3:WriteLn(A,' ч = ',(A/24):0:3,' сут = ',A*3600,' сек = ',A*60,' мин');
   4:WriteLn(A,' сут = ',A*24,' ч = ',A*1440,' мин = ',A*86400,' сек');
   End;
   WriteLn;
   WriteLn('Выберите тип единицы измерения времени: 1 - секунда, 2 - минута, 3 - час, 4 - сутки, 0 - выход.');
   ReadLn(R);
   End;
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика