Составить программу поиска первых n чисел, равных сумме кубов своих цифр. программа - паскаль аbc

ПАШАСАШАXAXAXAXXAXA ПАШАСАШАXAXAXAXXAXA    1   18.07.2019 20:40    2

Ответы
oliver6no oliver6no  07.09.2020 15:28
Var
n, i, s, x: integer;
begin
readln(n); //вводим n
for i:=1 to n do //проверяем каждое число от 1 до n
begin
s:=0; x:=i;
while x > 0 do //находим сумму кубов цифр
begin
s:=s + (x mod 10) * (x mod 10) * (x mod 10);
x:=x div 10;
end;
if s = i then //если сумма кубов равна i выводим i
writeln(i);
end;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика