tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Составить программу по паскалю!
Составить программу по паскалю! определить количество чисел с цифрой 4 в записи числа
Tishukvasiliy
3 15.08.2019 06:00
3
Ответы
chelikteliklol
04.10.2020 20:26
Var
ar:array[1..2000] of integer;
n,i,count:integer;
begin
readln(n);
for i:=1 to n do begin
read(ar[i]);
while ((ar[i]>0) and ((ar[i] mod 10)<>4)) do ar[i]:=ar[i] div 10;
if ar[i] mod 10 = 4 then inc(count);
end;
writeln(count);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
adamabiev
01.04.2019 05:30
1сравните размеры памяти,необходимые для хранения изображений: первое изображение 4-цветное,его размер 64х128 пикселей; второе изображение 16-цветное,его размер 32х32 пикселей....
FACCE
01.04.2019 05:20
Дана символьная строка всюду букву а поменять на букву в...
vitaska1971oz3tq3
13.05.2020 07:45
Рассмотрите изображение. Расставьте порядок действий созданияобъекта...
Ymnichkaaaaaa
13.05.2020 07:45
Опишите последовательность создания трехмерной модели в программе скетчап первая Орбита второе выдавить 3 прямоугольник 4 и Круг 5 повернуть 6 выбор 7 панорама 8 перемещение...
Юля5900274
13.05.2020 07:45
Тема: Оглавление Необходимо написать конспект на данную тему. Материал можно взять как с учебника так и с дополнительной литературы жнлательно за час-два написать уже...
Appolinaria06
13.05.2020 07:45
Какой модуль дает возможность приблизить внешний вид объекта к натуральному?...
ТаняСажнева486
13.05.2020 07:45
надо!3.1 Напишите значение S , полученное во время выполнения программы...
алина3706
16.06.2019 07:10
Запишите самое большое четырехрязоадное число в двенадцатеричной системе числения...
aytanpashaeva
16.06.2019 07:10
Логическое выражение: 1) (x1 v x2) & (x1 v x2) 2) (x1vx1)v(x2vx2)v(x3vx3)...
Lbailieva
24.05.2019 21:20
Написать программу паскаль -перенести первое число в конец число трехзначное : )...
Популярные вопросы
_ - исходное и основополагающее свойство права, придающее ему качество специфического...
2
Предмет исследования, ограниченный во времени (действующее законодательство)...
3
Основоположниками и основными теоретиками исторической школы права являются...
1
Для содержания разветвленного государственного аппарата власти, не принимающего...
1
Одним из основоположников психологической теории происхождения государства...
1
По мере развития общественного сознания и общества в целом все более увеличивается...
2
Вершины своего развития _ теория достигает тогда, когда становится теоретической...
3
Метод познания окружающей действительности, состоящий в мысленном переносе...
2
_ право как нравственные и правовые идее, принципы, идеалы, требования не...
2
Общественные науки называются гуманитарными точными естественными...
3
ar:array[1..2000] of integer;
n,i,count:integer;
begin
readln(n);
for i:=1 to n do begin
read(ar[i]);
while ((ar[i]>0) and ((ar[i] mod 10)<>4)) do ar[i]:=ar[i] div 10;
if ar[i] mod 10 = 4 then inc(count);
end;
writeln(count);
end.