Написать программу паскаль -перенести первое число в конец число трехзначное : )

Lbailieva Lbailieva    2   24.05.2019 21:20    4

Ответы
Tillll Tillll  20.06.2020 19:52
var a, b, c, d: integer;
begin
     readln(d);
     a := d div 100;
     b := d mod 100 div 10;
     c := d mod 10;
     writeln(b, c, a);
end.

можно ещё сократить:
var a, b, c, d: integer;
begin
     readln(d);
     writeln(d mod 100 div 10, d mod 10, d div 100);
end.

или даже:
var a, b, c, d: integer;
begin
     readln(d);
     a := d div 100;
     writeln(d - a * 100, a);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика