Составить программу паскаль и объясните ее дано четырехзначное число,получить новое поменяв местами первую и последнюю цифру

Sveta0202 Sveta0202    3   19.06.2019 13:50    2

Ответы
MIGSTERY10 MIGSTERY10  02.10.2020 05:26
Program zamena;
var s:string;
     x,y:char;
begin
write('Введите четырехзначное число: ');
readln(s);
x:=s[1]; y:=s[4];
s[1]:=y; s[4]:=x;
writeln('Полученное число: ',s);
end.

Считываем число как строку. Символьной переменной "X" присваиваем значение первого символа строки (первой цифры числа). Символьной переменной "Y" присваиваем значение четвертого символа строки (четвертой цифры числа). Делаем обмен первой и четвертой цифры числа: присваиваем первому символу значение переменной "Y", а четвертому символу - значение переменной "X". Выводим получившуюся строку (число) на экран.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика