Составить программу, определяющую, все целые числа из промежутка от 300 до 600, у которых сумма делителей кратна 10. язык: с++; ps: нужно решить при do_while

ЮЮПР ЮЮПР    3   14.08.2019 18:50    4

Ответы
avoka avoka  04.10.2020 19:22

#include <iostream>

using namespace std;


int main () {

    

    int digit = 300;

    

    do {

        int sum = 0;

        int teiler = 1;

        

        while (teiler <= digit)

        {

            if (digit % teiler == 0)

                sum+=teiler;

            

            teiler++;

            

        }

        

        if(sum % 10 == 0)

        {

            cout << digit << endl;

        }

        

        digit++;

        

    } while (digit <= 600);

    

    return 0;

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика