Составить программу на языке С++, решающую следующую задачу: Дано трехзначное число.
Найти сумму и произведение его цифр.

Den12364665 Den12364665    2   29.04.2020 16:24    6

Ответы
Pantiik Pantiik  28.08.2020 16:35

#include <iostream>

int main()

{

int N, s1 = 0, s2 = 1;

setlocale(LC_ALL, "Russian");  // Русский язык в консоли

std::cin >> N;

while (N > 0)

{

 s1 += N % 10;

 s2 *= N % 10;

 N /= 10;

}

std::cout << "Сумма: " << s1 << std::endl;

std::cout << "Произведение: " << s2;

return 0;

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика