Составить программу на языке паскаля: даны числа a,b,c. составить программу, выводящую на экран сообщение, в зависимости от того какой треугольник можно построить с такими длина сторон:
равносторонний,равнобедренный или какой либо другой.

KeKoLolist KeKoLolist    3   10.03.2019 00:30    8

Ответы
Vanpal03 Vanpal03  24.05.2020 13:09

var a,b,c: integer;

begin

  readln(a,b,c);

  if (a>b+c) or (b>a+c) or (c>a+b) then begin writeln('Треугольник не сущесвует'); exit; end;

  if (a=b) or (b=c) or (a=c) then writeln('Равнобедренный треугольник');

  if (a=b) and (b=c) and (a=c) then writeln('Равносторонний треугольник');

  if (sqr(c)=sqr(a)+sqr(b)) or (sqr(b)=sqr(c)+sqr(a)) or (sqr(a)=sqr(b)+sqr(c)) then writeln('Прямоугольный треугольник');

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика