Составить программу на С++ Создайте массив из 10 ячеек числа введите на клавиатуре от 1 до 10.Выполняя сортировку выбором.​

Kinder2571 Kinder2571    2   12.12.2020 21:14    1

Ответы
SuperVai SuperVai  11.01.2021 21:16

#include <iostream>

using namespace std;

int main() {

int a[10],size=10,min,temp;

for (int i = 0; i < 10; i++) {

 cin >> a[i];

}

 

for (int i = 0; i < size - 1; i++) {

 min = i;

 for (int j = i + 1; j < size; j++) {

  if (a[j] < a[min]) {

   min = j;

  }

  temp = a[i];

  a[i] = a[min];

  a[min] = temp;

 }

}

for (int i = 0; i < 10; i++) {

 cout << a[i] << " ";

}

return 0;

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика