Составить программу на паскале.вычислить корни квадратного уравнения, заданного коэффициентами a, b, c (предполагается, что а< > 0 и что дискриминант уравнения неотрицателен)

fox370 fox370    3   04.06.2019 08:50    1

Ответы
komissar1809 komissar1809  05.07.2020 11:27
Var   a,b,c,D,x1,x2:real;
begin
write('Введите коэффициенты a, b, c: ' );
readln(a,b,c);
D:= b*b-4*a*c; 
if D>0 then 
   begin
   x1:=(-b-sqrt(D))/2/a;
   x2:=(-b+sqrt(D))/2/a;
   writeln('Два корня: ',x1,' и ',x2)
   end;
if D=0 then
   begin
   x1:=-b/2/a;
   writeln('Один корень: ',x1)
   end;
if D<0 then writeln('Корней нет')
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика