Составить программу на паскале. в массиве хранится информация о стоимости каждой из m книг. определить количество самых дешевых книг(с одинаковой минимальной ценой)

ks441934 ks441934    2   09.08.2019 21:20    4

Ответы
miravolkova19 miravolkova19  04.10.2020 08:03
Var mas:array of integer;    min,kol ,j, i,n:integer;
begin
Randomize; min:=0;kol:=0;
write('n:' );
readln(n);   
setlength(mas,length(mas)+n);///динамический массив вы можете заменить на статический 
 For i:= 0 to high(mas) do 
  mas[i]:=Random(50);   
min:=mas[0]; 
 for j:=0 to high(mas) do//ищем минимальную ценну 
 if min>mas[j] then 
 min:=mas[j] ; 
 For i:= 0 to high(mas) do 
 if min=mas[i] then//ищем количество книг с минимальной ценой
   inc(kol);   
write('kolvo min  ',kol); 
 readln;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика