Составить программу на паскале с цикла с неизвестным числом повторений. "на первый же день появления красавца васи в колледже в него влюблялись 2 девочки. с каждым днем их число увеличивалось в два раза, но каждую неделю 23 девочки разочаровывались в нем и влюблялись в сережу. через сколько дней в васю влюбятся 45 девочек? "

vitalik2312031 vitalik2312031    2   31.07.2019 06:00    2

Ответы
denian11343 denian11343  03.10.2020 18:17
Var k,n:integer;
begin
n:=1;
k:=2;
while k<=45 do
 begin
 n:=n+1;
 k:=k*2;
 if n mod 7 = 0 then k:=k-23;
 end;
writeln('n = ',n,' k = ',k);
end.

Результат:
n = 6 k = 64
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика