Контрольная работа № 3
НАЧАЛО ПРОГРАММИРОВАНИЯ
1. Определите значение переменной c после выполнения следующей программы:
var a, b, c: integer;
begin
a:= 10;
b:= 30;
a:= a + b * 3;
if a > b then c:= a - b else c:= b - a;
writeln (c);
end.

2. Запишите значение переменной s, полученное в результате работы программы:
var s, k: integer;
begin
s := 0;
for k := 1 to 7 do
s := s + 6;
writeln (s);
end.

3. Дана программа:
var s,t: integer;
begin
readln(s);
readln(t);
if (s > =10) or (t > 10)
then writeln ("ДА")
else writeln ("НЕТ")
end.
Было проведено 8 запусков программы, при которых в качестве значений переменных s и t вводились следующие пары чисел:
(11, 2); (1, 12); (11, 12); (–11, –12); (–11, 12); (–12, 11); (10, 10); (10, 5).
Сколько было запусков, при которых программа напечатала «ДА»?

4. Составьте программу нахождения суммы первых 20 натуральных чисел.

Алинулька11 Алинулька11    1   12.05.2020 09:49    19

Другие вопросы по теме Информатика