Составить программу, которая проверяла бы, не приводит ли суммирование двух целых чисел а и в к переполнению (т.е. к результату большему чем 32 767). если будет переполнение, то сообщить об этом, иначе вывести сумму этих чисел.

lili2003love12 lili2003love12    3   23.05.2019 16:10    8

Ответы
nasty3yatskova nasty3yatskova  19.06.2020 10:05
Int A,B,Summ
A+B=Summ
if (Summ>32767) cout>>"Переполнение"
else cout>>"Summ"
ПОКАЗАТЬ ОТВЕТЫ
a01065699799 a01065699799  19.06.2020 10:05
Var
a, b, s  : Integer;
begin
Write('введите a= ');
readln(a);
Write('введите b= ');
readln(b);
S:=a+b;
if s<32767 then writeln(s) else writeln('произошло переполнение');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика