Составить программу, которая бы запрашивала хнач и хкон и определяла произведение всех положительных чисел от хнач до хкон (решить , используя цикл с предусловием – while .. do). пож

vetoss2 vetoss2    1   31.07.2019 17:30    11

Ответы
Pechencka666 Pechencka666  03.10.2020 18:48
//Pascal WDE

Var
 xk,xn:real;
 i,r,xik,xin:integer;
 b:boolean;
begin
b:=false;
r:=1;
read(xn,xk);
xin:=round(xn-frac(xn));
xik:=round(xk-frac(xk));
i:=xin;
while i<=xik do
begin
if i>0 then
 begin
  r:=r*i;
  b:=true;
 end;
inc(i);
end;
if b=true then write(r) else write('0');
end.

Пример ввода:
-2.8
3.8
Пример вывода:
6
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика