Составить программу - калькулятор, которая запрашивает тип функции: 1-квадрат, 2-куб, 3 - корень квадратный, 4 - обратная функция, а также аргумент функции x и вычисляет для x соответствующую функцию. ввод чисел заканчивается нажатием клавиши 0. протокол работы программы: выберите тип функции: 1-квадрат, 2-куб, 3 - корень квадратный, 4 - обратная функция, 0- выход. 1 введите аргумент функции: 5 ответ: 5*5=25 выберите тип функции: 1-квадрат, 2-куб, 3 - корень квадратный, 4 - обратная функция, 0- выход. 4 введите аргумент функции: 4 ответ: 1/4=0,25 выберите тип функции: 1-квадрат, 2-куб, 3 - корень квадратный, 4 - обратная функция, 0- выход.

podvorskij podvorskij    1   30.08.2019 06:10    5

Ответы
lexanyreev lexanyreev  06.10.2020 04:30
Var
   f:byte;
   x:real;
Begin
WriteLn('Выберите тип математической функции:');
WriteLn('1 - квадрат, 2 - куб, 3 - корень квадратный, 4 - обратная функция, 0 - выход.');
ReadLn(f);
While f <> 0 do
   Begin
   Write('Введите x: ');ReadLn(x);
   Case f of
   1:
     if x < 0 then WriteLn(x,'*(',x,') = ',x*x)
     else WriteLn(x,'*',x,' = ',x*x);
   2:
     if x < 0 then WriteLn(x,'*(',x,')*(',x,') = ',x*x*x)
     else WriteLn(x,'*',x,'*',x,' = ',x*x*x);
   3:
     if x < 0 then WriteLn('√',x,' = ',Sqrt(-x),'i')
     else WriteLn('√',x,' = ',Sqrt(x));
   4:
     if x = 0 then WriteLn('Ошибка: на ноль делить нельзя!')
     else if x < 0 then WriteLn('1/(',x,') = ',1/x)
          else WriteLn('1/',x,' = ',1/x);
   End;
   WriteLn;
   WriteLn('Выберите тип математической функции:');
   WriteLn('1 - квадрат, 2 - куб, 3 - корень квадратный, 4 - обратная функция, 0 - выход.');
   ReadLn(f);
   End;
End.

Пример работы программы:

Выберите тип математической функции:
1 - квадрат, 2 - куб, 3 - корень квадратный, 4 - обратная функция, 0 - выход.
1
Введите x: -8
-8*(-8) = 64

Выберите тип математической функции:
1 - квадрат, 2 - куб, 3 - корень квадратный, 4 - обратная функция, 0 - выход.
3
Введите x: 14
√14 = 3.74165738677394

Выберите тип математической функции:
1 - квадрат, 2 - куб, 3 - корень квадратный, 4 - обратная функция, 0 - выход.
4
Введите x: 0
Ошибка: на ноль делить нельзя!

Выберите тип математической функции:
1 - квадрат, 2 - куб, 3 - корень квадратный, 4 - обратная функция, 0 - выход.
4
Введите x: 16
1/16 = 0.0625

Выберите тип математической функции:
1 - квадрат, 2 - куб, 3 - корень квадратный, 4 - обратная функция, 0 - выход.
0
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика