Составить программу формирования массива из 50 элементов, в которой используется признак р, в зависимости от значения которого реализовывался бы один из массива: при р= -1 с генератора случайных чисел, при р=0 с формулы а[i] = i +101, при р=1 с клавиатуры. сделать вывод сформированного массива на экран.

annamasha2004 annamasha2004    2   12.09.2019 17:30    9

Ответы
dasha89011 dasha89011  07.10.2020 10:06
Const n=50;
var a: array[1..n] of integer; 
  p,i: integer;
begin
write('p (-1,0,1) = ');
readln(p);
case p of
 1: for i:=1 to n do a[i]:=random(100);
 0: for i:=1 to n do a[i]:=i+101;
-1: begin for i:=1 to n do read(a[i]); readln; end;
    end; 
writeln;
writeln('Исходный массив:');
for i:=1 to n do write(a[i],' ');
writeln;
end.

Пример (для n=5):
p (-1,0,1) = 0
Исходный массив:
102 103 104 105 106
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика