Напишите программу для решения пользуйтесь операции div и mod 1.задано двузначное число. найдите средняя арифметическая цифр числа 2.задано двузначное число. найдите разность между количеством десятков и единиц 3. дана масса в граммах. переведите её в килограммы и граммы 4. площадь участка изменяется в арах. найдите количество полных км в квадрате

egorsinitsyn9Egor egorsinitsyn9Egor    3   06.10.2019 14:50    5

Ответы
brijet2007 brijet2007  09.10.2020 23:45
1)var
n:Integer;
a:array [1..10] of Integer;
begin
Read(n);
a[1]:=n mod 10;
n:=n div 10;
a[2]:=n mod 10;
Write((a[1]+a[2])/2);
end.
2) var
n:Integer;
a:array [1..10] of Integer;
begin
Read(n);
a[1]:=n mod 10;
n:=n div 10;
a[2]:=n mod 10;
Write(a[2]-a[1]);
end.
3) var
n,m:Integer;
begin
Read(n);
m:=n div 1000;
Write(m,'кг',' ',n-m*1000,'г' );
end.
4)var
n,m:Integer;
begin
Read(n);
m:=n div 10000;
Write(m,'километров квадратных');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика