tutotveti.ru
Предметы
Биология
Физика
Українська мова
Музыка
Французский язык
Обществознание
МХК
Право
ОБЖ
Психология
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Русский язык
Английский язык
Окружающий мир
Алгебра
Другие предметы
История
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Составить программу для вычисления
Составить программу для вычисления значений переменной y при заданном значении n.(использовать три различных оператора цикла) y=
Сонечко1001
1 25.08.2019 04:10
11
Ответы
sokolovasvetla1
05.10.2020 18:00
Var
y:real;
n,i:integer;
Begin
Write('n = ');ReadLn(n);
{Цикл с параметром:}
y:=0;
For n:= 1 to n do
y:=y+(1/n);
WriteLn('y = ',y);
{Цикл с постусловием:}
y:=0;
i:=1;
Repeat
y:=y+(1/i);
i:=i+1
Until i>n;
WriteLn('y = ',y);
{Цикс с предусловием:}
y:=0;
i:=1;
While i<=n do
Begin
y:=y+(1/i);
i:=i+1
End;
WriteLn('y = ',y)
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
liza20038333
08.08.2019 13:50
Укажи, какому информационному действию соответствует наблюдение за птицами? обработка передача хранение сбор представление заранее...
3508
16.06.2019 09:30
Укажите правильный порядок убывания единиц измерения информатиции: байт,мбайт,кбайт,гбайт...
Damirzic
16.06.2019 09:30
Дан массив из 8 элементов целого типа равный : -8,13,4,-6,7,10,-5.напишите программу ,которая заменит все положительные числа на 1 ,а все отрицательные увеличит на 10.преобразованный...
7gklass2017
16.06.2019 09:30
Составить программу ,которая формирует массив ,содержащий 12 случайных целых чисел ,принадлежащий промежутку [-7; 10],и подсчитывает кол-во всех отрицательный чисел...
ULYA1111111
24.07.2019 19:10
Найдите сумму чисел 1 сотни, которая делится на 3. , ....
жасик0071
10.06.2019 22:00
Определить по номеру дня недели соответствующее название. составить программу с использованием оператора выбора. (1-понедельник, 2-второник и т.д)...
tylkinavaleriya
12.06.2019 00:03
Для какого наименьшего числа a формула (3x+y...
ycidenis1
11.06.2019 23:44
Отредактировать код что бы не было в строках. c++#include #include #include #include #include #define m 5#define n 2using namespace std; struct fio{ char fam[100]; char name[100];...
муха68
11.06.2019 23:44
Написать программу, которая запрашивает у пользователя координаты точки на плоскосости(х, у) и определяет принадлежность точки заштрихованной области. с++...
pkfz178
11.06.2019 23:39
Решите подробно с объяснениями , буду ....
Популярные вопросы
Сколько атомов n ртути содержится в капле ртути (hg) ассой m=9,5г?...
2
Составить план сочинения по произведению тарас бульба на тему остап и андрий...
3
Почему бирюк отпустил провинившегося мужика...
2
Сколько целых чисел принадлежит интервалу -1.51000...
2
Число увеличилось на 20%, затем то, что получилось,уменьшили на 20%. как в результате...
2
1.вставить пропущенные буквы: my house is cl__n. it is very . there is a gr__n...
3
1) cos2x=1/2 2) sinx/3=√3/2 3) tgx/2=√3 4) ctg3x=√3/3 5) 4sinx+3=0 6) 7cosx-2=0...
2
Верно: 1)стальной рельс 2)легкая сандалета 3)детская сандалия 4) тапок...
3
12 3 nacl-- cl2-- mgcl2-- agcl 1) овр 2) р.и.о....
1
Определить форму вины! 1) 1 апреля петров решил пошутить над своим приятелем...
1
y:real;
n,i:integer;
Begin
Write('n = ');ReadLn(n);
{Цикл с параметром:}
y:=0;
For n:= 1 to n do
y:=y+(1/n);
WriteLn('y = ',y);
{Цикл с постусловием:}
y:=0;
i:=1;
Repeat
y:=y+(1/i);
i:=i+1
Until i>n;
WriteLn('y = ',y);
{Цикс с предусловием:}
y:=0;
i:=1;
While i<=n do
Begin
y:=y+(1/i);
i:=i+1
End;
WriteLn('y = ',y)
End.