Составить программу для решения квадратного уравнения a*x*x+b*x+c=0

Daniil199511 Daniil199511    2   12.09.2019 19:30    2

Ответы
arystan307 arystan307  07.10.2020 10:20
Var
  a, b, c, D: integer;
  x, x2: real;

begin
  write('Введите a: ');
  readln(a);
  write('Введите b: ');
  readln(b);
  write('Введите c: ');
  readln(c);
  D := sqr(b) - 4 * a * c;
  if D > 0 then begin
    x := (-b - sqrt(D)) / 2 * a;
    x2 := (-b + sqrt(D)) / 2 * a;
    writeln('x1 = ', x, newline, 'x2 = ', x2);
  end;
  if D < 0 then writeln('Корней нет.');
  if D = 0 then begin
    x := (-b) / 2 * a;
    writeln('x = ', x);
  end;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика