Напишите программу в Python, которая получает на вход нижнюю и верхнюю границу диапазона целых чисел соответственно (ввод нажатием на клавишу после каждого числа), а выводит все числа, которые при делении на 15 дают в остатке 11, а при делении на 11 дают в остатке 9.

MadamHlebushek11 MadamHlebushek11    3   05.07.2020 21:23    6

Ответы
ZнyцPлaй ZнyцPлaй  19.08.2020 06:15

n_bott = int(input("Least number of interval - "))

n_top = int(input("The largest number of interval - "))

num_list = []

for num in range(n_bott,n_top + 1):

   if ((num % 15 == 11) and (num % 11 == 9)):

       num_list.append(num)

print(*num_list)


Напишите программу в Python, которая получает на вход нижнюю и верхнюю границу диапазона целых чисел
ПОКАЗАТЬ ОТВЕТЫ
lapshinauly lapshinauly  19.08.2020 06:15

#Более экономная по памяти версия

lb, rb = map(int, input('Enter lower and upper range borders:\n').split())

cond = lambda item: item % 15 == 11 and item % 11 == 9

[print(item, end='\n') for item in filter(cond, range(lb, rb+1))]

ввод:

100 1000

вывод

251

416

581

746

911

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика